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CONTENTS: 

Sr. 

No. 

Subject Content 

1. Hardware elements of the computer system 

 RAM 

 ROM 

 Motherboard 

 Processor 

 Input Devices 

 Output Devices 

 Different types of port 

2. Software 

 Introduction to different software 

 Installation of software 

 Un-installation of Software 

3. Presentation and Report Making 

 Word processing Software 

 Presentation Software 

4. Spreadsheet Software: 

Sum, Sumif, Count, Countif, if, averge, averageif, upper, lower, Hyperlink, SIN, 

COS, MAX , Date, Roundup, sqrt, time, today 

5. Internet 

 Steps to keep your computer secure 

 Firewall 

 Virus and Antivirus 

 Proxy Server 

6. Introduction to Programming Language 

 Why Programming Language? 

 Different Programming Language 

 Why C? 

 

 

Bridge Course duration :  04 Weeks  

 

Suggestion:- 

In the first hour, teacher will introduce and discuss the topic in detail. Here a naïve approach can be 

followed : Every students should carry pencil and pen, at the end of each topic every students should show 

either pen if they understood the topic otherwise pencil. Because many students hesitate to say if they have 

any doubt. In this technique all the students will give their opinion (understood or not). 



In the second hour, teacher will divide students into group and ask each and every group to do some activity 

and prepare set of questions.  

At the last 20 minutes each group will ask questions to the other group. 

Time Duration for each Activity with outcomes 

Sr. No. Activity Time Required Outcome 

1 Identify various hardware elements of 

the computer system. (eg. RAM, 

ROM, Motherboard, input device, 

output device, etc. if possible show the 

physical hardware instead of diagrams 

of RAM, motherboard and all the 

possible device) 

 

 

2 hours  Naïve user become 

familiar with 

computer 

 learn how to 

operate the 

computer 

 learn the 

connections 

between diff. 

devices 

 

2 Installing and uninstalling software 

(Explain step by step procedure to 

install and uninstall any one software 

or operating system) 

 

2 hours  Learn how to install 

the software 

 Learn how to 

uninstall the 

software 

 Understand usage 

of Software 

 Learn difference 

between two 

software 

 

3 Introduction to basic software like 

Open Office (here you can make 

groups and ask them to use all the 

open office tools and make 

report(using word), and ppt) 

 

2 hours  Learn how to use 

word processor 

 Learn how to create 

reports , slides 

using word 

processor 

4 Spreadsheet Software 

 

2 hours  Learn how to use 

spreadsheet 



 Maintain and 

analyse different 

data using 

spreadsheets 

5 How to make your computer secure? 

(eg. by making sure that it is being 

downloaded from some standard site, 

making secure payment transactions 

and other such security tips for 

working with internet) 

 

2 hours  Learn about e-

commerce also they 

will be introduced 

to firewalls 

 Understand the 

threat for 

computing world 

 Finding out 

different security 

mechanism for 

standalone, LAN 

and also for the 

internet. 

 

6 Introduction to Programming 

Languages, Why we need to learn 

Programming Languages, Which are 

the different Programming Languages, 

Why C?  

 

2 hours  They can map the 

real world problem 

to programs 

 They will know that 

C is a fundamental 

language and 

powerful 

 It is easy to create 

drivers in C  

 

7 Last week :- Interaction with students 

if they came up with some new idea or 

they know about any latest 

technology. Group presentation and 

Report Submission 

 

2 hours Students will present 

whatever knowledge  

they gained in Bridge 

course 

 

 

 

 

 

 



Evaluation for the evaluation of Bridge course 

Evaluation should be done on continuous-basis as mentioned below: 

At the end of each activity students should be evaluated out of 5 marks based on their interest, participation 

in the class and completion of task assigned to their group. 

And at the last week of bridge course, students have to submit a report which should contain whatever 

knowledge they gained in ICT bridge course and they have to present it in group. This report and 

presentation should be evaluated out of 20 marks based on the topics covered in the report, presentation 

skills, slides prepared and team work. 

Total Marks =6*5+20 =50 

 

Learning Resources :- 

 

Course Material :-  

 Presentations, Video and Course planning are provided. 

 

Books:-   

1) Fundamentals of Computers by V. Rajaraman 

2) Computer Studies - A first course by John Shelley and Roger Hunt 

3) Computer Fundamentals, MS Office and Internet & Web Technology by Dinesh Maidasani 

 

Useful sites :-  

http://www.bleepingcomputer.com/tutorials 

http://cybersecurityforindia.blogspot.in 

http://ptlb.in/csrdci/wp-content/uploads/2014/01/Cyber-Security-Must-Be-An-International-Issue.pdf 

http://www.howstuffworks.com/ 

 

Suggested Activities:  

 

Activity -1 

Identify various hardware elements of the computer system. 

Activity 2 

Explain step by step procedure to install any operating system 

Activity 3 

Introduction to basic software like Office (here you can make groups and ask them to use all the office tools 

and make report(using word), charts(using excel) and ppt) 

Working with word processing softwares. 

1.) To Copy Paragraph 

 Say you've written a report in Word. You like the look, especially your headings, which are 14 pt. 

Bookman Old Style, centered, green, and bold, with a nice subtle shadow. 

http://www.bleepingcomputer.com/tutorials/
http://cybersecurityforindia.blogspot.in/
http://ptlb.in/csrdci/wp-content/uploads/2014/01/Cyber-Security-Must-Be-An-International-Issue.pdf
http://www.howstuffworks.com/


 Fifteen minutes before you're supposed to present the report to the team, your manager asks you to 

add four new sections to the report. You spend thirteen minutes adding the information, and the 

next two wishing that you hadn't chosen such complicated formatting for your headings, since you 

now have to apply it to all the new ones. 

 Using Format Painter saves you that time and duplicated effort. Instead of having to manually apply 

the font, font effects, centered paragraph alignment, and other formatting to each new section 

heading, you can quickly copy all of the formatting attributes by using one toolbar button. 

 To copy formatting 

 Do one of the following: 

To copy both paragraph attributes (such as alignment, indentation, and so on) and character 

attributes (such as font and font effects), select the text whose formatting you want to copy plus the 

paragraph mark that follows the text. 

To copy only character attributes, select the text without selecting the paragraph mark. 

 On the Standard toolbar, click Format Painter .Select the text you want to apply the formatting 

to. 

The text takes on the new formatting. 

 If you want to apply the same formatting to more than one item, select the formatting you want, 

double-click Format Painter, and then select each word, phrase, or paragraph you want to apply 

formatting to. When you're finished, press ESC. 

2.) To make three column word document 

 Select the text you want formatted in columns, or place your cursor where you want columns to 

begin. 

 On the Page Layout tab, in the Page Setup group, click Columns. 

 Click More Columns. 

 Click the number of columns that you want. 

 In the Apply to list, click Selected text or This point forward. 

3.) To Set Paragraph Margin 

 You can change the spacing between the lines or the spacing before or after each paragraph. 

 Select the text you want to change. 

 On the Formatting toolbar, point to Line Spacing , and then do one of the following: 

 To apply a new setting, click the arrow, and then select the number that you want. 

 To apply the most recently used setting, click the button. 



 To set more precise measurements, click the arrow, click More, and then select the options you 

want under Line Spacing. 

 NOTE   If you select Exactly or At least for line spacing, enter the amount of space you want in 

the Atbox. If you select Multiple, enter the number of lines in the At box. 

 Select the paragraphs in which you want to change spacing. 

 On the Format menu, click Paragraph, and then click the Indents and Spacing tab. 

 Under Spacing, enter the spacing you want in the Before or After box. 

4.) To Insert APicture In Word Document 

 To insert a picture from your scanner or camera, use the software that came with your scanner or 

camera to transfer the picture to your computer. Save the picture, and then insert it by following 

these steps. 

 Click where you want to insert the picture in your document. 

 On the Insert tab, in the Illustrations group, click Picture. 

 

 

NOTE   Some commands shown are not available in Word Starter. 

 Locate the picture that you want to insert. For example, you might have a picture file located in My 

Documents. 

 Double-click the picture that you want to insert. 

 NOTE   By default, Microsoft Word embeds pictures in a document. You can reduce the size of a 

file by linking to a picture. In the Insert Picture dialog box, click the arrow next to Insert, and 

then click Link to File. 

 To resize a picture, select the picture you've inserted in the document. To increase or decrease the 

size in one or more directions, drag a sizing handle away from or toward the center, while you do 

one of the following: 

 To keep the center of an object in the same location, press and hold CTRL while you drag the 

sizing handle. 

 To maintain the object's proportions, press and hold SHIFT while you drag the sizing handle. 

 To both maintain the object's proportions and keep its center in the same location, press and hold 

both CTRL and SHIFT while you drag the sizing handle. 



 Working with presentation softwares for making good presentation. 

1.) Create a hyperlink to a slide in the same presentation 

 In Normal view, select the text or the object that you want to use as a hyperlink. 

 On the Insert tab, in the Links group, click Hyperlink. 

 Under Link to, click Place in This Document. 

 Do one of the following: 

 Link to a custom show in the current presentation: 

 Under Select a place in this document, click the custom show that you want to use as the 

hyperlink destination. 

 Select the Show and return check box. 

 Link to a slide in the current presentation: 

 Under Select a place in this document, click the slide that you want to use as the hyperlink 

destination. 

2.) Insert clip art 

 Do the following for all programs listed in the Applies To at the top of the article. 

 On the Insert tab, in the Illustrations group, click Clip Art. 

 

 In the Clip Art task pane, in the Search for text box, type a word or phrase that describes the clip 

art that you want, or type all or some of the file name of the clip art. 

 To narrow your search, do one or both of the following: 

 To limit the search results to a specific collection of clip art, in the Search in list, select the check 

box next to each collection that you want to search. 

For more information about collections, see About Clip Organizer collections. 

 To limit the search results to clip art, in the Results should be list, select the Clip Art check box. 

You can also select the check boxes next to Photographs, Movies, and Sounds to search those 

media types. 

 Click Go. 

 In the list of results, click the clip art to insert it. 



3.) Change a slide layout 

 If you do not find a standard slide layout that matches your slide content, you can change an 

existing layout. 

 On the View tab, click Slide Master. 

 In the thumbnail pane that contains the slide masters and layouts, locate and click the slide layout 

that is the closest match to what you want in your layout. 

 TIP    If none of the layouts meet your needs, select the Blank Layout and start anew by adding 

placeholders to contain text, pictures, videos, etc. 

 To change an existing layout, do one or more of the following: 

 To add a placeholder, on the Slide Master tab, click Insert Placeholder, and then select a 

placeholder type from the list. Click a location on the layout, and then drag to draw the placeholder. 

 Resize, reposition, or delete a placeholder. 

 To rename the layout, in the thumbnail list of layouts, right-click the layout that you customized, 

and then clickRename Layout. 

 In the Rename Layout dialog box, type a new name that describes the layout you’ve just created, 

and then click Rename. 

 On the Slide Master tab, click Close Master View. 

 To reapply the updates you made to the layout so that they appear on the slides in your 

presentation, do the following: 

 In Normal View, in the thumbnail pane, click the slide that you want to reapply the updated layout 

to. 

 

 

 

 

 

 

 

 

NOTE    To select multiple slides, press and hold the Ctrl key, and then click each slide. 

 On the Home tab, in the Slides group, click Layout, and then select the layout that you updated in 

Slide Master View. 



Activity 4 

Working with spreadsheet software and understanding the usage of formulas.  

ABS function 

Description: 

Returns the absolute value of a number. The absolute value of a number is the number without its sign. 

Syntax: 

ABS(number) 

COS function 

Description: 

Returns the cosine of the given angle. 

Syntax: 

COS(number) 

FACTDOUBLE function 

Description: 

Returns the double factorial of a number. 

Syntax: 

FACTDOUBLE(number) 

SINH function 

Description: 

Returns the hyperbolic sine of a number. 

Syntax: 

SINH(number) 

TAN function 

Description: 

Returns the tangent of the given angle.Syntax: TAN(number) 

Activity 5 

Create gmail account with id name.surname-collegename@gmail.com 

Email forwarding using POP3/ IMAP 



How to create labels and folders in gmail account. 

How to create google sites. 

Tell the students about Google scholar. 

How to make your computer secure? (eg. by making sure that it is being downloaded from some standard 

site, making secure payment transactions and other such security tips for working with internet) 

1. Do you need to be connected to the internet all the time? 

2. Make sure your router has a decent firewall 

3. Make sure your Computer or Device has a decent firewall 

4. Install Decent Anti-virus Software 

5. Keep Your Computer Up to Date! 

6. Don’t Visit Porn Sites (or any other dodgy or affected site)! 

7. Keep Your Password Safe and Hard to Guess. 

8. Use a Decent Web Browser 

9. Don’t Trust Public Wifi 

10. Never Leave Your Computer Unattended 

What you need to know to keep your computer safe on the Internet 

 

Tip 1: Always install Operating System updates 

Tip 2: Keep your installed applications up-to-date 

Tip 3: Do not use the same password at every site 

Tip 4: Install and be sure to update your anti-virus software 

Tip 5: Use a firewall 

Tip 6: Backup your data! 

Tip 7: Enable the display of file extensions 

Tip 8: Do not open attachments from people you do not know 

Tip 9: Ignore emails that state you won a contest or a stranger asking for assistance with their inheritance 

Tip 10: Watch out for online and phone support scams 

Tip 11: Ignore web pop ups that state your computer is infected or has a problem 

Tip 12: Ignore and close web pop ups that pretend to be a Windows alert 



Tip 13: Some types of web sites are more dangerous than others 

Tip 14: Be vigilant when using Peer-To-Peer Software 

Tip 15: When installing a piece of software, watch out for "bundled" tool bars and programs that you may 

not want 

Tip 16: When installing a piece of software, read the End User License Agreement (EULA) so you know 

what your getting into 

Activity 6 

Introduction to Programming Languages, Why we need to learn Programming Languages, Which are the 

different Programming Languages, Why C? 

 

 

 


